Carlson Motorsports

mikelavite#72

Premium User
Just wanted everyone to know . i just got my Open Flathead back from Brian Carlson today . well it came in a few days ago. But i just got my hands on it today . And i am just very pleased . and i havnt even started it yet . . when i meet with Brian and his family in Indiana and dropped off my engine . it was very quick meeting . but i knew i had the wright people to weld up and ffix my little nasty flatty ! It looks awsome out of the box . and i had alot of spare parts with me when the Carlsons picked up the engine . and all the extra and spare parts were shipped back with it . this is a first time i have ever ussd a builders shop that has returned my extra or parts that i sent with a engine that they couldnt use
And thats a great thing . to the Carlsons . im very happy thank you for the repairs and rebuild . ot was outside my comfortzone . i hope this weekend i get the free time to mount it up . and start getting Jenna and myself back on the race track . also. I have never had a Engine packed that way . i was about to call the shop and ask if you guys could email me some opening instructions . i could harddley get the box open . i think fedex could have flew over my house and did a airdrop . and i could race the engine the next day . AWSOME PACAGING JOB !!


OK ....THANKS SO MUCH
Mike Lavite
 
Agreed. I called about tires and he suggested something different than what I had in mind and different than everyone else at my track is running, and it works well. He took the time to talk to me, and I was never made to feel like I was wasting his time.
Completely satisfied is how I would describe that transaction.
 

fastbraden11

FAST N LOUD
Brians one of those who has gone beyond to help folks out and the hands of the business,sarahs probably the backbone of the operation with all the calls and questions,known both for many yrs,,outstanding folks
 

pignoliracing69

Premium User
Well sorry to say but I got a paper weight from them , sent a Flathead to them to be a stock appearing , thing has never ran right , leaked oil first time I ran it , changed carb , still the thing is a dog , won't rev over 6500 rpm , worst experience ever !
 

Brianf60

Member
Did you contact them? What was their response? Its fair to say everyone makes mistakes the question is how did the handle it when they were contacted?
 

OVALTECH1

Premium User
not saying this is what happened in your case but I’ve seen a poorly setup overly tight chassis or locked down over prepped tires pull 1,000 rpm out of a usually happy motor real quick like... hope everything gets worked out for you.
 

racing promotor

Moderator
not saying this is what happened in your case but I’ve seen a poorly setup overly tight chassis or locked down over prepped tires pull 1,000 rpm out of a usually happy motor real quick like... hope everything gets worked out for you.
I've seen being badly gear bound give similar results as well.
 

pignoliracing69

Premium User
not saying this is what happened in your case but I’ve seen a poorly setup overly tight chassis or locked down over prepped tires pull 1,000 rpm out of a usually happy motor real quick like... hope everything gets worked out for you.
It was last year , when I first got it put on a kart the kart was in last place , came off track noticed oil everywhere , changed motor immediately , did much better than last, I did contact them , was told to replace the breather , I did , no oil , then put on kart the following week , only got 6500 rpms , took motor off for the night , took it home changed carb , same thing the following week , took off and been a paper weight ever since , I never did contact them out of fustration
 

pignoliracing69

Premium User
I’m sure beyond a shadow of a doubt that Brian would have rectified the problem he would have dynoed it first then if there was a problem he would have rectified it
Ya probably but it was not dynoed before sent to me
 
It was last year , when I first got it put on a kart the kart was in last place , came off track noticed oil everywhere , changed motor immediately , did much better than last, I did contact them , was told to replace the breather , I did , no oil , then put on kart the following week , only got 6500 rpms , took motor off for the night , took it home changed carb , same thing the following week , took off and been a paper weight ever since , I never did contact them out of fustration

I'm sorry to hear about this, Albert. We thought that the oil leak problem was rectified and that all was well with the engine. Yea, that was at least a year ago, maybe two now. If there's anything we can do to make it right, give us a call at the shop or drop me a note on here. I'd sure like to hear more abut what was going on with that engine that it wouldn't rpm. Could be something as simple as jetting in a stock appearing. We'd sure like to know more and how we can help.
 
Top