Intermittent Miss

Looking for suggestions on the cure to my problem. I have two identical engines 460cc Big Blocks that both have intermittent misses at full speed under a load. Runs great on stand but engines Miss while on track during races but not every lap. I have changed coils I have also changed spark plugs and tried different brands of spark plugs. Both also have new fuel pumps.
Any and all suggestions will be greatly appreciated thanks in advance.
 

flattop1

Dawg 89
What rpm is full speed ?
Are they stock ?
Jet changes ?
Need better details , for any possible guess .
 

flattop1

Dawg 89
Some times too rich will cause that .
A loose valve seat .
Stuck ring will but seems to be a problem always .
No intermittent .
Try a colder plug .
 

CarlsonMotorsports

Premium User
^ Agreed. The Mikuni is a much more user-friendly carb that's easy to tune - pretty much plug-n-play.

Also check your coil air gap -- spark can become weak at high rpm with stock ignition gapped too far off the flywheel.

-----
🏁Thanks and God bless,
Brian Carlson
Carlson Racing Engines
Vector Cutz
www.CarlsonMotorsports.com
Carlson Motorsports on Facebook
30 years of service to the karting industry
Linden, IN
765-339-4407
bcarlson@CarlsonMotorsports.com
 

CarlsonMotorsports

Premium User
Coil gap is .065
I'd close it up some if it were mine, but doubtful that is your problem (the stock clone guys run upwards of that.)
Float height and drop sufficient for your build?
Sounds like a ton of spring pressure and cam/rpm for a stock carb, but I have no idea of the parameters of your whole build.
Is it just missing at peak rpm (would make me think it's too rich) or is it missing when you hit the throttle (ie too lean)?
You said it has an adjustable jet - have you tried adjusting it? Did it help/hurt?
 
Definitely fuel related. We run 30 lap features and it misses once just before going into the corners. Once per race it will just cut out through the whole corner then take back off. Both engines doing the same thing.
 
Top